XH Odometer Problems? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-24-2005, 04:10   #1 (permalink)
Registered User
 
Join Date: Apr 2005
Location: Mandurah WA
Age: 33
Posts: 4
XH Odometer Problems?

Hi I currently own a 97 Xh faclon ute 5spd manual tradesman all stock standard and in the last 3 weeks have encountered a problem with the digital odometer.

I started the car on the thursday 3 weeks ago and the odometer read 160955 and tripmeter 740.2. Since that day everytime the car is switched off and restarted no matter how long I have been driving the car's odometer returns to 160955 and tripmeter 740.2.

Any ideas as to wot might be causing the odometer to do this?

Also when the cars gets hot it struggles/cant be started to turn over any idea wot may cause that?

Any help greatly apprececiated

XH Falcon ute
xhfalconute is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-26-2005, 09:22   #2 (permalink)
Can't wait for Winton...
 
outback_ute's Avatar
 
Join Date: Jul 2003
Location: Victoria
Posts: 2,759
Re: XH Odometer Problems?

Obviously the odometer thinks the car is not going anywhere, they are all electronic so it could be a loose connection somewhere. At least you're keeping your mileage down! Not sure on starting issue assuming battery etc is ok.
outback_ute is offline   Reply With Quote
Old 04-29-2005, 09:13   #3 (permalink)
Registered User
 
Join Date: Apr 2005
Location: Mandurah WA
Age: 33
Posts: 4
Re: XH Odometer Problems?

Had the car looked at by Ford, Odometer cluster is stuffed and was quoted 600 dollars to replace not bad highway robbery!

As for the none started while hot cant be identified as yet.
xhfalconute is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 07:00.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.