2.9i not starting!! PLEASE HELP - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Granada | Ford Scorpio Forum for the discussion of the Ford Granada and Ford Scorpio.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-22-07, 06:05 PM Thread Starter
Registered User
 
Join Date: May 2007
Posts: 2
2.9i not starting!! PLEASE HELP

Hi guys, i need my car for the rust 2 rome rally which leaves in 9 days and its recently broken down...

here's the symptoms... it broke down gradually over period of 2 weeks. The power went down and down until it became undrivable due to lack of power... now it will not start. It almost starts if you give it full throttle and will chug over for a few turns then just dies.. sounds like its getting flooded or something.

I've checked some stuff - it's good compression, spark, gettin petrol, injectors are gettin power and it's still not runnin.

I'm totaly stuck with this engine cos i dont know enough about it... can anyone give me a few pointers?

it's a 2.9 efi without the air metering blocks in the inlet manifold pipes.

If anyone can help please let me know!!

Thanks a lot guys, Marko

Rust2Rome is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-29-07, 09:42 AM
Registered User
 
Fordtech.'s Avatar
 
Join Date: Apr 2003
Location: UK
Posts: 687
Re: 2.9i not starting!! PLEASE HELP

Is this the Cosworth engine?
Fordtech. is offline  
post #3 of 4 (permalink) Old 05-29-07, 03:23 PM Thread Starter
Registered User
 
Join Date: May 2007
Posts: 2
Re: 2.9i not starting!! PLEASE HELP

no it's the 12 valve version...
Rust2Rome is offline  
 
post #4 of 4 (permalink) Old 05-26-08, 05:26 PM
Registered User
 
Join Date: May 2008
Posts: 7
Re: 2.9i not starting!! PLEASE HELP

check fuel pressure that feeds the injectors , fuel filter blocked or fuel pump ?

Also this must have a cam or crank shaft sensor that could be faulty but i would look into fuel supply first
540itouring is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Granada | Ford Scorpio


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome