Ignition Switch Problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Granada | Ford Scorpio Forum for the discussion of the Ford Granada and Ford Scorpio.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-07-07, 10:37 AM Thread Starter
Registered User
 
Join Date: May 2007
Posts: 1
Ignition Switch Problems

I am having problems with a scorpio I have recently bought. When ever I pull out the key the lights come on low and the stero stays on. I'm not entirley sure what is wrong but I am thinking of connecting a simple swtich to the livewire from the battery and placing it on the dash. Is it easy to do? I had a similair switch years ago in another car and thought this would solve the problem.

Also if it is possible which colour wire am I attaching the switch too?

Thanks

MechJerk is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-08-07, 03:56 PM
Registered User
 
Fordtech.'s Avatar
 
Join Date: Apr 2003
Location: UK
Posts: 687
Re: Ignition Switch Problems

If you're referring to the interior light coming on when you take out the key, I'm pretty sure this is a normal convenience feature. Maybe the radio wiring's at fault.
Fordtech. is offline  
post #3 of 3 (permalink) Old 04-19-08, 05:02 AM
Registered User
 
Join Date: Apr 2008
Posts: 3
Re: Ignition Switch Problems

check fuse box for water common fault shorts out when powered down some ties lights will come on when ever they wish not good when your some where and battery winds up flat.
mickyjay is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Granada | Ford Scorpio


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome