No lights - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Granada | Ford Scorpio Forum for the discussion of the Ford Granada and Ford Scorpio.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-11-09, 01:49 PM Thread Starter
First On Race Day
19Fairmont82's Avatar
Join Date: Feb 2008
Location: Southern Indiana
Posts: 7
No lights

Ok, I know that this is not a Granada, but it is close. I have a 1982 Fairmont. I had a problem a while back with a fusible link. I bypassed the link with a new wire to the ignition. Now, I have no lights. Head or parking, front or rear. I do have brake, hazard, and turn lights. When I start the car, it the headlight switch is on, the lights come on until I return the key to run. Help me. Please.
19Fairmont82 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Granada | Ford Scorpio
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome