Territory heater now cold - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Territory Ford Australia Upcoming CrossOver vehicle discussion forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-26-10, 10:40 PM Thread Starter
Registered User
 
Join Date: Nov 2010
Posts: 3
Territory heater now cold

Territory heater not working. The dashboard dial does not seem to be connected. Any ideas ? What part needs replacement and what part of the dashboard requires removal ?

John3 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-03-10, 02:42 PM
fordmech
 
backlash1's Avatar
 
Join Date: Jun 2007
Location: NSW Australia
Age: 45
Posts: 315
Re: Territory heater now cold

It all depends on what model it is (ie: how old) and what part has failed.
Before you start pulling things apart, try disconnecting the battery for a few minutes to reset the HIM. More often than not this makes everything work normally again. If not, then you need to know if it's a HIM or a blend door failure, but both of them will require the dash to come out for repair, unless it's the very latest model, where you can access the HIM without removing the dash.
backlash1 is offline  
post #3 of 3 (permalink) Old 12-19-10, 07:00 PM Thread Starter
Registered User
 
Join Date: Nov 2010
Posts: 3
Smile Re: Territory heater now cold

Ford Territory model is 2004. Will try disconnecting the battery for a few minutes and reset the HMI. Thank you for yor help. Regards John3.
John3 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Territory
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome