02 explorer theft light ( help)! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-03-06, 07:13 PM Thread Starter
Registered User
 
Join Date: May 2006
Posts: 2
02 explorer theft light ( Problem diagnosed and repaired)!

I have a 2002 Exp. When driving at highway speed the theft light comes on, when it does it seems to go into neutral . If i step on the gas I can hear the engine Rev. but the vehicle won't go. After about two or three seconds the light goes out and I can step on the gas and the vehicle goes like nothing has happened. I took it to my local dealer they had it for two days, and they don't know what the problem is. They said they would do some research and get back to me. Nothing Yet (two days). Any one have this problem?

wheelnut is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-20-06, 05:49 AM Thread Starter
Registered User
 
Join Date: May 2006
Posts: 2
Re: 02 explorer theft light ( help)!

Problem solved!!!

Luckily, the part is considered a part of the powertrain, so it was still covered under the warranty.

The powertrain control module went bad, causing the transmission to either disengage every so often (Usually at the worst time) or the vehicle would just shut off, (Again, at the complete wrong time...).

They replaced the PCM and now everything is fine.
wheelnut is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome