03 Explorer - Cruise control problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-04-2005, 06:01   #1 (permalink)
Frank from Deeeetroit
Guest
 
Posts: n/a
03 Explorer - Cruise control problem

My cruise control quit working on my 2003 Ford Explorer. I suspect the
issue is a fuse. The On switch does not activate the instrument panel light
and no speed can be set over 45 mph.

When I push the Set button, the panel light ligh comes on but the speed
cannot be set.

Any ideas?

Thanx in advance.


Frank from Deeetroit


  Reply With Quote
Sponsored Links
Advertisement
 
Old 09-04-2005, 08:01   #2 (permalink)
jimmyh
Guest
 
Posts: n/a
Re: 03 Explorer - Cruise control problem

sounds like the cruise control switch it mounts on the bottom of the
master cylinder ford has had a lot of trouble with this catching fire the
did have a recall on the explorer dont remember what year need to look at
yours and see if the wires or switch is burnt and i would check and see if
they had a recall on your year

  Reply With Quote
Old 09-04-2005, 12:01   #3 (permalink)
Backyard Mechanic
Guest
 
Posts: n/a
Re: 03 Explorer - Cruise control problem

"jimmyh" <jimmyheltonh@aol.com> wrote in
news:ae5f394cee54f74bf11abd41024d541d@localhost.talkaboutautos.com:

> sounds like the cruise control switch it mounts on the bottom of the
> master cylinder ford has had a lot of trouble with this catching fire
> the did have a recall on the explorer dont remember what year need to
> look at yours and see if the wires or switch is burnt and i would
> check and see if they had a recall on your year
>


http://www.cnn.com/2005/US/06/16/ford.vehicle.faq/

Symptom of fault that has caused hundreds of cars to burn in driveways and
garages

Get to the dealer pronto if that list fits your Exploder.
  Reply With Quote
Old 09-04-2005, 16:01   #4 (permalink)
johanb
Guest
 
Posts: n/a
Re: 03 Explorer - Cruise control problem

The "cruise" lite never comes on when pushing the "on" button, only when you
push "set"

I would check the cruise control switch on the master cylinder, doesn't
hurt, for brake fluid residue.

If ok, check your brake lites


"Frank from Deeeetroit" <dadurweird@voyager.net> wrote in message
news:sJSdnX7bB7m7d4feRVn-1g@comcast.com...
> My cruise control quit working on my 2003 Ford Explorer. I suspect the
> issue is a fuse. The On switch does not activate the instrument panel

light
> and no speed can be set over 45 mph.
>
> When I push the Set button, the panel light ligh comes on but the speed
> cannot be set.
>
> Any ideas?
>
> Thanx in advance.
>
>
> Frank from Deeetroit
>
>



  Reply With Quote
Old 09-05-2005, 17:01   #5 (permalink)
Frank from Deeeetroit
Guest
 
Posts: n/a
Re: 03 Explorer - Cruise control problem

Thanx for everyones response, will call the dealership tomorrow to set up an
appointment.

Maybe I am on the beginning of some having kind of problem, the "Door Ajar"
light came on today and all doors are secure.

Checked all the lights, tail lights, turnsignals, all are working. The
cruise control switch and all connections to it and the master cylinder seem
to be ok, I do not see any obvious signs of fluid leaaking from the MS, so
who knows at this point.

Again, thanx for all of your advice.

Frank


"Frank from Deeeetroit" <dadurweird@voyager.net> wrote in message
news:sJSdnX7bB7m7d4feRVn-1g@comcast.com...
> My cruise control quit working on my 2003 Ford Explorer. I suspect the
> issue is a fuse. The On switch does not activate the instrument panel
> light and no speed can be set over 45 mph.
>
> When I push the Set button, the panel light ligh comes on but the speed
> cannot be set.
>
> Any ideas?
>
> Thanx in advance.
>
>
> Frank from Deeetroit
>



  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 19:26.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.