03 explorer sport - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-24-06, 11:06 AM Thread Starter
Registered User
 
Join Date: Apr 2006
Posts: 2
03 explorer sport

hello fam i'm new to this scene and i have a question about my girls truck... When sitting at a light it will start to sputter a lil but the rpms wont drop i have done a tune up on it along with a fuel filter change but that didn't solve the problem.. Someone told me that it could be the coil pack oh yeah and i also replaced the egr valve too... thanks for any help.. Oh yeah when you put it in reverse it sputters badly ....

bigslim007 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-13-06, 03:17 AM
Robot dude
 
mulebiscuit's Avatar
 
Join Date: Dec 2005
Location: Upstate SC
Posts: 11
Re: 03 expolerer sport

Clean and lightly lube the IAC. If this dosent work try using some contact cleaner and cleaning the MAF sensor but be carefull as it is a very fine wire. Both of these can cause idle issues and are common problems with the 4.0 engine.

2005 Mustang screaming yellow A5
2004 GTO Barbados Blue A4
mulebiscuit is offline  
post #3 of 3 (permalink) Old 09-27-06, 06:54 AM
Registered User
 
BK Lawson's Avatar
 
Join Date: Aug 2006
Location: Indiana
Posts: 18
Re: 03 expolerer sport

Thanks for this advice, MB!
It seems that every time I fill my '04 4.0L up, then start it, when the new gas hits the motor, it has a momentary hernia or something...
Also get this a lot when first starting in the mornings. According to the book and advice from the dealer, it's because the truck has to figure out what kind of gas it's getting because of the Flex-Fuel motor setup. I'll be sure to jot this down, though.
BK Lawson is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome