04 Mountaineer Transmission - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-22-10, 01:11 PM Thread Starter
Registered User
 
Join Date: Jan 2010
Posts: 3
04 Mountaineer Transmission

I have a 2004 Mountianeer. Lately, the transmission has been acting erratically. It shifts very hard and/or slips at times and sometimes takes a while to shift into gear when going from reverse to drive (and vice versa).

Took it to the shop and the mechanic said it sounded like a bad solenoid. Two questions:

1) has anyone had these kinds of problems and if so, what was the issue?

2) mechanic said replacing the solenoid would cost about $400. Does that sounds reasonable?

Thanks in advance for any help you guys might be able to provide!
bsc33 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome