1994 Ford explorer xlt problems. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-29-2006, 18:32   #1 (permalink)
Registered User
 
Join Date: Nov 2006
Posts: 1
1994 Ford explorer xlt problems.

I want to start off by saying that I have replaced my fuel pump, egr valve, the air control sensor, and the battery terminals as advised by my machanic.

My serious problems with the suv is that no matter how far down I press the gas pedal when taking off from an idle position, or giving it gas to go faster, the suv just chugs along, or has serious lack of power, and when idle it shuts off, and the idling is really bad, then I have to restart it. I have spent alot of money fixing parts, and my problem is getting worse day by day. My mechanic told me he doesnt know what else it could be. The check engine light also comes on, and the exhaust fumes dont smell normal.

Can anyone help?

Thanks in advance.
stevlo10 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-03-2006, 09:19   #2 (permalink)
Registered User
 
Join Date: Nov 2006
Location: Martin SD
Age: 70
Posts: 62
Re: 1994 Ford explorer xlt problems.

Quote:
Originally Posted by stevlo10
the exhaust fumes dont smell normal.

Can anyone help?

Thanks in advance.
How about the exhaust system--stopped up Cat will give you low power--bad idle and a SMELLY exhaust--also check condition of oxygen sensors--may be defective causing a rich condition---bobr19
bobr19 is offline   Reply With Quote
Old 12-07-2006, 20:47   #3 (permalink)
Hi-Tech Redneck
 
Johnny Mullet's Avatar
 
Join Date: Jun 2006
Location: Ashtabula, Ohio
Age: 43
Posts: 1,486
Re: 1994 Ford explorer xlt problems.

Bad fuel pump or clogged filter. I would start there.

A plugged cat would do it also. Please get a scan and post the check engine codes here for more help.
Johnny Mullet is offline   Reply With Quote
Old 12-21-2006, 07:16   #4 (permalink)
Registered User
 
Join Date: Dec 2006
Posts: 17
Re: 1994 Ford explorer xlt problems.

kinda like my problem, i just posted another thread, hope to get awnsers!
grub5891 is offline   Reply With Quote
Old 02-08-2007, 13:48   #5 (permalink)
Registered User
 
Join Date: Dec 2006
Posts: 17
Re: 1994 Ford explorer xlt problems.

got no awnsers for mine here, thinking to find a different site, seem like most here are into hot rodding and not doing actual repairs.......grub
grub5891 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 00:30.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.