1994 Ford explorer xlt problems. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 11-29-06, 05:32 PM Thread Starter
Registered User
 
Join Date: Nov 2006
Posts: 1
1994 Ford explorer xlt problems.

I want to start off by saying that I have replaced my fuel pump, egr valve, the air control sensor, and the battery terminals as advised by my machanic.

My serious problems with the suv is that no matter how far down I press the gas pedal when taking off from an idle position, or giving it gas to go faster, the suv just chugs along, or has serious lack of power, and when idle it shuts off, and the idling is really bad, then I have to restart it. I have spent alot of money fixing parts, and my problem is getting worse day by day. My mechanic told me he doesnt know what else it could be. The check engine light also comes on, and the exhaust fumes dont smell normal.

Can anyone help?

Thanks in advance.

stevlo10 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 12-03-06, 08:19 AM
Registered User
 
Join Date: Nov 2006
Location: Martin SD
Age: 72
Posts: 62
Re: 1994 Ford explorer xlt problems.

Quote:
Originally Posted by stevlo10
the exhaust fumes dont smell normal.

Can anyone help?

Thanks in advance.
How about the exhaust system--stopped up Cat will give you low power--bad idle and a SMELLY exhaust--also check condition of oxygen sensors--may be defective causing a rich condition---bobr19
bobr19 is offline  
post #3 of 5 (permalink) Old 12-07-06, 07:47 PM
Hi-Tech Redneck
 
Johnny Mullet's Avatar
 
Join Date: Jun 2006
Location: Ashtabula, Ohio
Age: 45
Posts: 1,486
Re: 1994 Ford explorer xlt problems.

Bad fuel pump or clogged filter. I would start there.

A plugged cat would do it also. Please get a scan and post the check engine codes here for more help.
Johnny Mullet is offline  
post #4 of 5 (permalink) Old 12-21-06, 06:16 AM
Registered User
 
Join Date: Dec 2006
Posts: 17
Re: 1994 Ford explorer xlt problems.

kinda like my problem, i just posted another thread, hope to get awnsers!
grub5891 is offline  
post #5 of 5 (permalink) Old 02-08-07, 12:48 PM
Registered User
 
Join Date: Dec 2006
Posts: 17
Re: 1994 Ford explorer xlt problems.

got no awnsers for mine here, thinking to find a different site, seem like most here are into hot rodding and not doing actual repairs.......grub
grub5891 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome