2003 Explorer 4.6 V8 idle problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-24-2014, 11:35   #1 (permalink)
Registered User
 
Join Date: Jul 2008
Age: 60
Posts: 8
mad 2003 Explorer 4.6 V8 idle problems

My 2003 4.6 V8 has a high idle problem. During warm months the engine will idle from 1500 - 2000 rpm. Real problem when coming to stop when it will bang into first gear before stopping. Dealer first said it was the idle air control. Replaced idle air control myself with a new ford one. No difference. Then read that I should disconnect the battery for a few hours, then connect, crank and idle in park, then in drive and then reverse for the computer to learn the idle patterns. That seemed to work for awhile. The car has not had the high idle almost the entire winter. Now that things have warmed up, it back to it's high idle problem. Does not do it all the time. Has anyone else has this experience. Please help.
capriIIs is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-27-2014, 18:23   #2 (permalink)
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 3,848
Re: 2003 Explorer 4.6 V8 idle problems

Have you tried cleaning the throttle body (MAF included?)
__________________
'Scuse me, while I scrape this Honda outta my treads.
CatSkinner is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 03:27.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.