2003 Ford Explorer No start/ Quit on Road - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-05-11, 11:03 AM Thread Starter
RTR
Registered User
 
Join Date: Feb 2011
Posts: 1
2003 Ford Explorer No start/ Quit on Road

03' ford explorer 4.0 sohc flex no start just cranks. checked fuel pressure 65-70 psi at rail, has spark, has 150- 135 psi compression at all cylinders. tore apart to cams, all chains and guides tight and present no deflection. bought cam alignment tools and set to top dead center, all line up w/ tools. I've tried to pcm, crank sensor, coil pack. It died on road and has never re-started. checked for codes has none. I have a snap-on modis and pid monitored this and everything looks good. I've got it to try to fire at times at wide open throttle it catches and shuts off just as fast. Dose anybody have any ideals, something i'm not thinking of? I was a Ford tech for 8 yrs.

RTR is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-05-11, 11:57 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,344
Re: 03' Explorer No start/ Quit on Road

Does it start if you spray carb cleaner or starting fluid in the intake? Does the spark look nice and blue at the plugs?

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome