2003 Mountaineer High Beam Inop - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-09-12, 03:17 PM Thread Starter
Registered User
 
Join Date: Feb 2009
Posts: 22
2003 Mountaineer High Beam Inop

High beam switch is not working. However, momentary high beams are fine. Suspect switch is bad adn wondering how to replace it?

kwaskow is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-09-12, 04:37 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,312
Re: 2003 Mountaineer High Beam Inop

Have you checked fuse # 46 under the hood? The switch is easy to replace. Remove the column covers and it's held on by 2 screws. No need to pull the steering wheel.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome