2004 Mountaineer - Air Blowing in at Glove Box - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-23-2006, 05:25   #1 (permalink)
Registered User
 
Join Date: Nov 2005
Posts: 21
2004 Mountaineer - Air Blowing in at Glove Box

Anyone else notice if outside air is always blowing in at highway speeds from the glove box area .... if opened, I can easily feel cold unheated feel air rushing in. At stop signs, I do not feel any air at the glove box even with the HVAC fan on high.

Does anyone know if this is normal for 2004 Explorers and Mountaineers?

Is there a cabin air filter on these units?

Thanks ... RR
RRod is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-29-2006, 09:55   #2 (permalink)
zobiedo
 
Join Date: Jan 2006
Age: 54
Posts: 2
confused Re: 2004 Mountaineer - Air Blowing in at Glove Box

Quote:
Originally Posted by RRod
Anyone else notice if outside air is always blowing in at highway speeds from the glove box area .... if opened, I can easily feel cold unheated feel air rushing in. At stop signs, I do not feel any air at the glove box even with the HVAC fan on high.

Does anyone know if this is normal for 2004 Explorers and Mountaineers?

Is there a cabin air filter on these units?

Thanks ... RR
Yes, I have had the same problem since I bought my Mountaineer. I don't know why it is happening but I am sorry to say I am glad I am not the only one with the problem.
zobiedo is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 06:44.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.