2005 Explorer XLT 4.0 Litre V-6 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-26-06, 01:21 PM Thread Starter
Registered User
 
Join Date: Mar 2006
Posts: 1
2005 Explorer XLT 4.0 Litre V-6

Vehicle has approx. 30,500 miles. Filled up with Exxon 87 octane gas in
Jackson, Mississippi on Wednesday morning, and less than 10 miles later
the engine started running very poorly and the "check engine" light
started flashing....then it died on the side of the road. Got it
cranked again and made it to a parking lot where it died again. Called
Ford roadside assistance and had it towed to a local dealership. They
ran the diagnostics tests and said that it had 2 bad fuel injectors
(number 3 & 6 cylinders). They replaced the injectors (which they did
not keep in stock, by the way, so we were stuck there overnight), but
they say that did not rectify the problem. Fuel filter was changed and
gas sampled OK, so they tell me.Now I'm told they are dismantling the
engine to find the root cause of the problem. Anyone have any ideas?
wbmcshane is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome