93 Explorer Issues -- Please help - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-03-06, 01:14 PM Thread Starter
Registered User
 
Join Date: Apr 2006
Posts: 1
93 Explorer Issues -- Please help

Since leaving my job with a company car, my self and my girlfriend have been forced to share her 93 ford explorer. She has owned it for a year and a half and prior to her, was only owned and garage kept by one owner. The car when purchased last year had 60K miles on it and now is at 70K (she doesnt drive much) and has had oil changes riligiously every 3,000 miles. The other day I noticed her engine was knocking loudly, so I went to advance autoparts, and got some additive that was supposed to make that stop. Now, one day later the knock is back... and I noticed that when driving the oil pressure drops to ZERO when below 1000 RPM or above 2000 RPM. Any idea's what's happened? Or how to fix it? It's our only form of transportation, and we are financially strapped -- so it's a tough situation. Is there anything we can do to prolong the use of the vehicle? Any suggestions at all? Prior to this the car has had no issues.

Thank you in advance!
chris300zx is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome