95 Explorer key?? Ignition problem help -desperate - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-28-09, 08:50 AM Thread Starter
Registered User
 
trulyblest's Avatar
 
Join Date: Feb 2007
Location: Ohio
Posts: 4
Question 95 Explorer key?? Ignition problem help -desperate

Hi,
Thanks for this forum. My 95 Ford Explorer has recently been acting strange. For days on end, it will turn over just fine. Then without notice, I will turn the key and it is quiet, no clicking noises or anything. It might take 2-3 times to turn it, or the last time it took about 17 times before it would turn over.

It will however sometimes trigger the automatic door lock. Strange thing, my Uncle told me to separate my keys, they were too heavy. After I separated them, that is when the problems started. (Like I was jinxed).

Note, my hubby had a heart attack and has been in the hospital. He will not be able to take care of this for me. I truly need your guys help. His best friend said it is probably the lock cylinder, or the ignition switch which he said would be an easy fix. Any ideas??

Thanks

trulyblest is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-28-09, 09:11 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,349
Re: 95 Explorer key?? Ignition problem help -desperate

Try it in Neutral too. It could be the Nuetral safety switch. There could also be a connection somewhere. The heavy keys would just wear out the tumblers and the key wouldn't turn. I would start with checking the battery cables. Make sure they're clean.
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome