96 exployer cold water - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-21-12, 08:51 PM Thread Starter
Registered User
 
Join Date: Feb 2012
Posts: 3
96 exployer cold water

I have 96 exployer which the upper and lower hoses are cold. the temp goes up in the truck with the heat working but when I open the radaitor cap which is cold also and the pressure of water comes out like a stream .
when I fill it back up with water and leave the cap off I can see the water being sucked down like it is working. can someone explain what is wrong with this

oldcar880 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-22-12, 04:38 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,815
Re: 96 exployer cold water

First thing I would check is the thermostat .
R.S.LOGAN is offline  
post #3 of 5 (permalink) Old 02-22-12, 05:38 AM Thread Starter
Registered User
 
Join Date: Feb 2012
Posts: 3
Re: 96 exployer cold water

Quote:
Originally Posted by R.S.LOGAN View Post
First thing I would check is the thermostat .
I put a new thermostat in yesterday which gave me heat in the truck. The thermostats cone part is facing towards the radaitor. Is their anything else I should check.
oldcar880 is offline  
post #4 of 5 (permalink) Old 02-22-12, 05:39 AM Thread Starter
Registered User
 
Join Date: Feb 2012
Posts: 3
Re: 96 exployer cold water

I put a new thermostat in yesterday which gave me heat in the truck. The thermostats cone part is facing towards the radaitor. Is their anything else I should check
oldcar880 is offline  
post #5 of 5 (permalink) Old 02-22-12, 06:41 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,815
Re: 96 exployer cold water

Top up , run engine and bleed cooling system if needed .
R.S.LOGAN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome