97 mountaineer shifting problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-16-08, 09:03 AM Thread Starter
Registered User
 
Join Date: Apr 2008
Posts: 1
97 mountaineer shifting problem

I recently aquired a 97 mountaineer AWD with auto transmission. I had to replace some fuel injectors to get it running smooth. Now when I drive it if I take off normally it seems to shift and run ok, but if I take off quickly it winds up pretty tight before it shifts and does not seem to have a lot of power. The same scenerio if I'm driving along and try to pass. It downshifts but does not seem to have any power.

Any thoughts

Scott

splummer is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-23-08, 01:12 PM
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,481
Re: 97 mountaineer shifting problem

Which engine?

I'd keep things simple and cost effective as possible. First off, change the transmission fluid and filter. Also, if a tune up hasn't been done in the last 30K, it's worthwhile to get new plugs, timing checked and spark plug wires installed if they're still original.

'11 Ram Quad Cab 4x4 SXT 5.7L HEMI (stock); 48,500m
'06 Pontiac G6 GT 3.5L 220hp; 64,000m
'12 Chrysler 200 Limited 3.6L 283hp; 28,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome