clicking in rear while stopping. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-13-09, 09:47 PM Thread Starter
Registered User
 
Join Date: Apr 2009
Posts: 1
clicking in rear while stopping.

My girlfreind just bought this 98 explorer with 124,000 on it. For state inspection purposes I put new parking brake pads, rotors and rear pads on it. Now when you stop there is a loud clicking noise coming from the back and i cant figure it out. I put the old rotors and pads on and it still does it. You dont hear anything while driving only when you hit the brakes and your going below 50 MPH. The clicking slows down with speed. I havent really messed with the parking brakes since changing shoes except to adjust them but i dont see where they could caude the noise....I dont know what to do. I need help!
zerogravity58 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome