Cruise control doesn't work.. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-20-06, 05:09 PM Thread Starter
Registered User
 
Join Date: Jan 2006
Location: Sacramento, CA.
Posts: 15
Cruise control doesn't work..

I have a 92 explorer which the cruise control hasn't worked for years. I 've checked for fuses and vacuum leaks but nothing visible. Anyone know anything about this?

Micky_B is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-20-06, 07:57 PM
Sho'n Off
 
98shotoy's Avatar
 
Join Date: Jul 2004
Location: Monroe, MI
Age: 40
Posts: 127
Re: Cruise control doesn't work..

I believe that the cruise is on a relay. So, most likely the relay would be under the hood. Do you have an owners manual that you can look up the location of the relay?

Matt
1998 SHO
2004 F150 STX
2003 Explorer XLT Limited
Monroe, MI

I'd rather be judged by twelve then carried by six
98shotoy is offline  
post #3 of 5 (permalink) Old 01-21-06, 10:10 AM Thread Starter
Registered User
 
Join Date: Jan 2006
Location: Sacramento, CA.
Posts: 15
Re: Cruise control doesn't work..

I have the Chilton's and found the wiring diagram...I see 2 fuses in the circut, both of which control other items as well. All of which work.
Micky_B is offline  
post #4 of 5 (permalink) Old 01-21-06, 03:16 PM
Unregistered
Guest
 
Posts: n/a
Re: Cruise control doesn't work..

Quote:
Originally Posted by Micky_B
I have the Chilton's and found the wiring diagram...I see 2 fuses in the circut, both of which control other items as well. All of which work.
Well, I am assuming that you are in need of a blinker assembly. Its the whole blinker knob on your steering column.
 
post #5 of 5 (permalink) Old 01-21-06, 03:17 PM
Sho'n Off
 
98shotoy's Avatar
 
Join Date: Jul 2004
Location: Monroe, MI
Age: 40
Posts: 127
Re: Cruise control doesn't work..

Quote:
Originally Posted by Micky_B
I have the Chilton's and found the wiring diagram...I see 2 fuses in the circut, both of which control other items as well. All of which work.

Then I am assuming you are in need of a blinker assembly.

Matt
1998 SHO
2004 F150 STX
2003 Explorer XLT Limited
Monroe, MI

I'd rather be judged by twelve then carried by six
98shotoy is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome