Dang explorer wont start - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-06-2009, 18:07   #1 (permalink)
Registered User
 
Join Date: Oct 2009
Posts: 2
Dang explorer wont start

It started up just fine today, but all of a sudden i go to start my car, and it wont start, i dont think its the batter cuz all the lights work, but a funny thing happens, when i turn the key, the brake light comes on, the abs comes on, and the airbag light comes on ( the one of a little guy getting hit with an airbag) yes, so i dont know if those things have anything to do with it. but any suggestions/help would be awesome thank you/
Guitarist383 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-06-2009, 18:13   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,809
Re: Dang explorer wont start

Those will come on with a weak battery. Have you tried jump starting it?
Bert is offline   Reply With Quote
Old 10-06-2009, 20:19   #3 (permalink)
Registered User
 
Join Date: Oct 2009
Posts: 2
Re: Dang explorer wont start

Yes i tried to jump start it would'nt work, i just replaced the starter a year ago, possibly the wires connecting? I just hope this isn't a big expensive job, i just fixed the radiator and put new tires, and now this happens.
Guitarist383 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 18:41.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.