Directionals not working / can't locate flasher relay - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-15-2009, 13:32   #1 (permalink)
Registered User
 
Join Date: Aug 2009
Posts: 1
Directionals not working / can't locate flasher relay

The fuse for the directionals in my 99 Explorer keeps on blowing. I was told to check the flasher relay. Supposively this is located under the steering column, however, I can't find it anywhere.

Does anyone know where it is? I want to determine if this needs to be replaced before trying the multifuncional switch (which costs more money).

Any insight is greatly appreciated - I'm a rookie when it comes to this stuff!
AKav is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-15-2009, 14:36   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,702
Re: Directionals not working / can't locate flasher relay

What else is connected to that fuse? Check the owners manual and see what else is connected to it. I think the flasher is in a body control module. I don't have access to a diagram for it so I'm not sure. The flasher normally won't blow a fuse. Neither will the switch. Something is shorting to ground.
Bert is offline   Reply With Quote
Old 08-15-2009, 16:07   #3 (permalink)
Multi-Group Moderator
 
tbird100636's Avatar
 
Join Date: Jan 2005
Location: Massachusetts
Age: 32
Posts: 1,825
cool Re: Directionals not working / can't locate flasher relay

It should be mounted to the Instrument Panel frame, near the DLC or the steering column, a seperate square relay with wires going to it, it may be black in color, or a high visibility color like yellow.



To the original poster, do you have a trailer connector?? If so check it for corrosion. If You find any this is most likely the cause of the fuse blowing.
__________________
Master ASE Certified L1 Chrysler Technician- still a Ford fan at heart.
1964 Thunderbird Hardtop- Chantily Beige- 390 FE 4V V8-Uncle's Car
1966 Thunderbird Convertible- Red- 390 FE 4V V8- Uncle's other car- waiting for paint and body work!!!
tbird100636 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 13:22.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.