EGR Vavle 96 Explorer - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-02-05, 07:40 PM Thread Starter
Jeffcozet
 
Join Date: Sep 2005
Location: Fort Smith, AR
Age: 41
Posts: 1
Question EGR Vavle 96 Explorer

My check engine light came on so I ran my Snap-On Diagnostics on it and it came up with an EGR code. I replaced the EGR and the code still shows up. The troubleshooter tells me to look for a vacuum leak but for the life of me I can't find one anywhere. Any Suggestions!!!

Jeffcozet is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-03-05, 03:24 AM
***** Idiot....
 
LunaticSVT's Avatar
 
Join Date: Feb 2001
Location: The Sticks of Central TX
Posts: 10,560
Re: EGR Vavle 96 Explorer

I would suggest that you ask this in the tech forums. You are more likely to get a better response there.
LunaticSVT is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome