engine noise from oil filter - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-20-07, 02:45 PM Thread Starter
Registered User
 
Join Date: Sep 2007
Location: Omaha, NE
Posts: 1
engine noise from oil filter

When complaining about a rattling sound from engine I was told that it was caused by using the wrong brand of oil filter, Something about residue getting into the valves or timing belt pulleys. Huh? Anybody ever hear of this?

jrod is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-21-07, 06:11 AM
Registered User
 
Join Date: Jun 2007
Posts: 32
Re: engine noise from oil filter

brand shouldn't matter. I didn't know the oil lubricates the pulleys. sounds like they may be pulling your chain to get you to switch to their oil changes.

noises from valves and timing belt pulleys should be very different. They just said it was both of them? Can you locate about where the noise is coming from?
KU40 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome