Explorer engine replaced now front end pulls - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-30-2009, 07:47   #1 (permalink)
Rmalko
 
Join Date: Jan 2009
Posts: 1
Explorer engine replaced now front end pulls

I just had my engine replaced in my 2000 Explorer. I drove it to work the next day and noticed it was pulling to the right slightly. I then got on the highway doing about 60 mph and hit a slight bump in the road. The front end shook violently. I didn't know if the engine was going to fall out or what. I slowed down and the shimy went away. I sped up again and no problem. I got off the highway and was doing about 20 mph and hit some bumpy road due to snow and ice. The front end shook again. I called the garage that replaced my engine and told them what my Explorer was doing. I said it did not have this problem before I brought it in for engine replacement. Do you think the garage is responsible for this and should fix it or is it my tough luck and I should pay for it? I am pretty ticked that the garage said I need some work done on it when it was fine before. I am open to any suggestions you may have. Thanks,

Rmalko
rmalko is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-30-2009, 21:49   #2 (permalink)
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,475
Re: Explorer engine replaced now front end pulls

Take it back!

The job was to install a new engine, not install a new engine half-assed! My guess here is that they didn't tighten the engine mounts correctly. If you drive over pot holes and the vehicle vibrates and you can feel the feedback in the steering wheel and gas pedal get them to fix it right away, as it's unsafe and the DOT will get you if you cause an accident.

If the shop gives you problems and you paid by credit card, you can phone the card company, and tell them you want to fight the charges and they'll credit you the amount until the garage can prove they did the job correctly (yeah right) or they fix the problem properly to your specifications. This is one of the few reasons why I own credit cards - to protect my sorry arse.
__________________
'00 Durango R/T 360ci 290hp (modded); 138,500m
'06 Pontiac G6 GT 3.5L 220hp; 44,000m
'12 Chrysler 200 Limited 3.6L 283hp; 13,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 08:26.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.