Ford Explorer 2003 AC blower sucks - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-21-07, 01:35 PM Thread Starter
Registered User
 
Join Date: Jun 2007
Posts: 1
Ford Explorer 2003 AC blower sucks

Anyone have a suggestion on how to get my AC blower to blow air. It only blows air if I crank up the fan all the way and then I can't here my self think.
Even then it takes about 20 min on high to get the inside of the SUV cold or Hot. This is a problem because I don't drive usually for more that 15 minutes anywhere with this SUV and I can't here the radio unless it is so load the guy next to me is singing along with me. Please help I am willing to pay for any con*****tion. Thank you in advance. Jim

FORDACSUCKS is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-21-07, 02:45 PM
Registered User
 
Join Date: Apr 2006
Posts: 71
Re: Ford Explorer 2003 AC blower sucks

Sounds like the blower motor resistor. Had the same happen on mine.
GJSmackdown is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome