Ford explorer stalls - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-09-2009, 09:20   #1 (permalink)
Registered User
 
Join Date: Apr 2009
Posts: 4
Ford explorer stalls

i have a 98 ford explorer with 155k miles. The truck has ran great for me but in the past few months it has been stalling when i approach a stop light or sign ect. It will shudder and shake then stall. I can put it back in park and start it but when i switch it back into drive it will shut off as if i turned the key off (it wont shudder again) i have to sit and wait about a minute then it will go back in drive and will go. It is very random and happens about 3 times a month and only if i drive over 10 miles at a time. I get no codes and mechanics cant figure it out. I have had the idle air controll valve replaced a major tune up new fuel filter and nothing has worked any suggestions?
snookslayer06 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-12-2009, 07:58   #2 (permalink)
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,475
Re: Ford explorer stalls

Possible MAF sensor problem. Can't really diagnose it without a code as you mentioned you already replaced the IAC. I could suggest some other things but to do them in hopes of it fixing the problem won't be worth the money as they're not cheap possible fixes. I know you spent a good deal already to solve the problem. Were new spark plug wires included with the tune up along with a distributor(?); I can't recall when the Explorers went to electronic ignition....
__________________
'00 Durango R/T 360ci 290hp (modded); 138,500m
'06 Pontiac G6 GT 3.5L 220hp; 44,000m
'12 Chrysler 200 Limited 3.6L 283hp; 13,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline   Reply With Quote
Old 04-12-2009, 13:39   #3 (permalink)
Registered User
 
Join Date: Apr 2009
Posts: 8
Re: Ford explorer stalls

I know the 96 that I am working on has Electronic Ignition. Just wires and plugs as far as I know.

This sounds kind of similar to my issues. Maybe possibly a weak Fuel Pump from trying to pump fuel through a completely clogged filter?

Just a thought...


Have you pulled any codes from the ECU for indicators of the issue?


Here is a link to my thread that I started and my issues. Any suggestions would be great...


96 Explorer V-6 4.0 starts then dies after 2-3 seconds
__________________
rockchucker is offline   Reply With Quote
Old 04-14-2009, 09:33   #4 (permalink)
Registered User
 
Join Date: Apr 2009
Posts: 4
Re: Ford explorer stalls

I had the plugs replaced in the tune up. Im going to check for vacuum leaks
snookslayer06 is offline   Reply With Quote
Old 04-28-2009, 13:05   #5 (permalink)
Registered User
 
Join Date: Apr 2009
Posts: 1
Re: Ford explorer stalls

I have the exact same problem on my 2002 explorer sport. My CEL is not showing. I have replaced my egr sensor and solenoid, my pcv valve, and cleaned my iac valve. It almost feels like if it were a standard that the clutch wasnt depressed when stopping. Did you ever find out what was wrong?
rshguam is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 20:43.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.