help with my navi? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-26-09, 07:54 AM Thread Starter
Registered User
 
Join Date: Feb 2009
Posts: 1
help with my navi?

hey guys I hadve a 2008 ford explorer, I just bought a 2009 mercury mountaneer navi. now i couldnt get it to power up so i called dealer. now they said that its a low power radio and would require a diff amp is there any way to drop the power down? or get this to work with my explorer?

stilmon is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome