Mid 80's Exploder Problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-09-2008, 20:37   #1 (permalink)
Registered User
 
Join Date: Aug 2008
Posts: 4
Mid 80's Exploder Problem

Friend has a mid 80's explorer with a V-6.....VERY strong exhaust smell....runs really rough...and has almost a choking sound to it....IDEAS ANYONE???
c17hydro is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-09-2008, 20:44   #2 (permalink)
Registered User
 
Join Date: Aug 2008
Posts: 4
Re: Mid 80's Exploder Problem

She also says that the check engine light is on....can still drive it but runs like crap.
c17hydro is offline   Reply With Quote
Old 08-09-2008, 20:44   #3 (permalink)
Registered User
 
Join Date: Aug 2008
Posts: 4
Re: Mid 80's Exploder Problem

She says the check engine light is on and is still driveable but runs like crap.
c17hydro is offline   Reply With Quote
Old 08-12-2008, 21:26   #4 (permalink)
Registered User
 
Join Date: Aug 2008
Posts: 4
Exclamation Re: Mid 80's Exploder Problem

Not many mechanics in here, huh?
c17hydro is offline   Reply With Quote
Old 04-22-2009, 15:00   #5 (permalink)
Registered User
 
Join Date: Apr 2009
Posts: 1
Re: Mid 80's Exploder Problem

its probably a bronco 2 cause the explorer wasnt introduced till 91 try the bronco2 forums
asteroth666 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 17:00.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.