Need help w/ Sport Trac electrical issue - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-24-2011, 14:18   #1 (permalink)
Registered User
 
Join Date: May 2011
Posts: 3
Exclamation Need help w/ Sport Trac electrical issue

My '07 4.0 ST was running fine yesterday morning... but when I left work, turning the key gave me:

*strong clunk* (starter engaging the flywheel)
*loud pop from somewhere under the dash*
*fast clicking* (like what a dead battery gives you)

When I let off the starter and yanked the key out, something somewhere under the dash was giving a hard click every second or two, for about half a minute, then softening to lighter, faster clicks for a minute or two, and cycling like that between harder and softer clicking periods. The harder ones I could feel in the fuse box under the dash, by the steering column.

Now, putting the key in and just turning it to Run gives the same fast clicking, as if it was trying to start but the battery was dead. (But it started strong yesterday morning and again at lunch, with no hint of sluggishness.) On turning the key to start, the "Passenger Airbag Off" light flickers and something in the throttle body seems to be clicking fast (I could feel it w/ my hand). Also, *after* attempting to start the engine (while trying to zero in on the clicking) and taking the key out, there is a series of slow clicks behind the dash, like relays moving. After these relay clicks, the 4WD lights and cruise control lights start flickering sporadically. It seems like power is running around randomly.

None of the lights work, including headlights and interior lights. Locks have no power. None of the fuses are blown, either in the main fuse box in the engine compartment or in the fuse box under the dash/by the driver's kick panel.

I have my theories, but they're only that. Does anyone have any ideas about or experience with this?
turnercm1776 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-24-2011, 15:36   #2 (permalink)
Moderators
 
Join Date: Apr 2007
Location: Scotland
Posts: 10,828
Re: Need help w/ Sport Trac electrical issue

Sounds like flat battery . Enough power to throw pinion forward but not to turn engine , then solenoid clicking . Tried charging battery or jump start ?
R.S.LOGAN is offline   Reply With Quote
Old 05-24-2011, 15:42   #3 (permalink)
Registered User
 
Join Date: May 2011
Posts: 3
Re: Need help w/ Sport Trac electrical issue

Quote:
Originally Posted by R.S.LOGAN View Post
Sounds like flat battery . Enough power to throw pinion forward but not to turn engine , then solenoid clicking . Tried charging battery or jump start ?
That's (one of) the odd parts... it cranked nice and strong for my morning commute and lunch break, then this... plus there was that loud *pop* somewhere under the dash (or in the engine compartment, near the firewall) when I tried to crank it after work. Plus power seems to be randomly getting to some components and not others... like my interior lights won't even dimly glow, & my locks won't even try, but a *few* of the dash panel back lights flicker, as if they were shorting.

Hell, at this point, I'll try anything.
turnercm1776 is offline   Reply With Quote
Old 05-24-2011, 15:59   #4 (permalink)
Moderators
 
Join Date: Apr 2007
Location: Scotland
Posts: 10,828
Re: Need help w/ Sport Trac electrical issue

If alternator was not charging correctly , battery could be run down . But could be knackered due to dud cell . Nothing to lose testing , charging or jump starting battery . That will eliminate one possible cause anyway .
R.S.LOGAN is offline   Reply With Quote
Old 05-24-2011, 16:04   #5 (permalink)
Registered User
 
Join Date: May 2011
Posts: 3
Re: Need help w/ Sport Trac electrical issue

Quote:
Originally Posted by R.S.LOGAN View Post
If alternator was not charging correctly , battery could be run down . But could be knackered due to dud cell . Nothing to lose testing , charging or jump starting battery .
Great point. It's easier than pulling the dash off, chasing a bad relay!

Any thoughts on what the heck persists in clicking, somewhere in the dash, until the battery is unhooked? It started with the loud pop yesterday.

Thanks for your help!
turnercm1776 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 05:21.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.