O/D light flashing - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-16-2008, 13:30   #1 (permalink)
Registered User
 
Join Date: Feb 2008
Posts: 1
O/D light flashing

I just dropped my 2003 Explorer off at the dealer. My O/D light started flashing and the transmission would not shift correctly. I have 102,000 miles on it and have never had a problem. This happen suddenly, no slipping no "clunking". Whats this going to cost me, any ideas ? or will it be cheaper to buy a for sale sign??????
leebert298 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-17-2008, 05:46   #2 (permalink)
Registered User
 
Join Date: Apr 2006
Posts: 71
Re: O/D light flashing

I had the same problem with a 95 Explorer 4.0 XLT. Took it to the dealer and they said it could just be a computer update is needed or it could be the transmission itself. I choose the computer update. It fixed the problem. But 4 months later I had to replace the transmission. Jasper trans 3yr 36,000 mile warranty $2800. The computer update was roughly $300 from Ford. If you've had no other problems with your Explorer I'd spend the money and replace the trans. But I wouldn't get it from Ford.
GJSmackdown is offline   Reply With Quote
Old 02-17-2008, 07:45   #3 (permalink)
Registered User
 
Join Date: Jan 2006
Posts: 45
Re: O/D light flashing

2002 XLT: same warnng light problem but along with sudden onset of slippage etc. at 104,000 miles. Innards were chewed up. Ended up with a rebuilt Ford transmisssion at a cost of $3800 but with 75,000 mile warranty. These original tranmissions are notorious for breakdown. You can have the codes scanned - maybe by someone who does not have a vested interest in selling you a transmission job, to see what the diagnosis is.
NCVinVT is offline   Reply With Quote
Old 04-18-2008, 00:50   #4 (permalink)
Registered User
 
Join Date: Apr 2008
Posts: 8
Re: O/D light flashing

I had the same problem with the flashing light. Mine would downshift on the freeway and would be up at like 5000 rpm, took it in and it ended up being the band for 2nd gear had broken :( 2200 dollars for a rebuild
Toratwin is offline   Reply With Quote
Old 04-27-2008, 10:01   #5 (permalink)
Multi-Group Moderator
 
tbird100636's Avatar
 
Join Date: Jan 2005
Location: Massachusetts
Age: 32
Posts: 1,826
cool Re: O/D light flashing

I had a 1999 Mountaineer with a 4.0L SOHC and a 5R55E trans that was doing this. The Ford dealer said to restart the vehicle, hit the O/D OFF button and take it for a drive. If the O/D OFF light no longer flashes it's an issue with the O/D OFF button. If the light still flashes the trans. has an internal issue.
__________________
Master ASE Certified L1 Chrysler Technician- still a Ford fan at heart.
1964 Thunderbird Hardtop- Chantily Beige- 390 FE 4V V8-Uncle's Car
1966 Thunderbird Convertible- Red- 390 FE 4V V8- Uncle's other car- waiting for paint and body work!!!
tbird100636 is offline   Reply With Quote
Old 04-28-2008, 06:27   #6 (permalink)
Registered User
 
stuford's Avatar
 
Join Date: Feb 2008
Posts: 10
Re: O/D light flashing

i used to have the same problem with my t-bird the dam elctronic transmission kept blowing out some selinoid that might be it
stuford is offline   Reply With Quote
Old 05-08-2008, 05:45   #7 (permalink)
Registered User
 
Join Date: May 2008
Posts: 3
Re: O/D light flashing

I have had this problem twice. The first time my tranny wasn't shifting right and the tranny eventually had to be replaced. The second time a wire had gotten pinched when the new tranny was put in and it would cut out and light would go on and off at random especially when hitting bumps in the road etc. Yesterday it started again but have no odd shifting problems and it's running fine this time.
bschwa74 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 07:49.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.