Oil Pressure Sending Unit - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-14-04, 06:28 AM Thread Starter
Registered User
 
Join Date: Dec 2004
Age: 50
Posts: 1
Oil Pressure Sending Unit

Does anyone know where the oil pressure sending unit is located on a 2000 Mercury Mountaineer V-8?

lumpytim is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
No oil pressure? Cobra Windsor Tech 16 08-25-04 08:11 AM
Oil pressure Question pippen Inline 6 Tech 8 08-14-04 07:51 PM
Worked i6 idle and oil pressure issues... Ideas? defective Inline 6 Tech 18 07-23-04 05:11 PM
1995 Contour - Low Oil Pressure after Head Gasket replaced BeoWolfe Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar 1 04-29-04 07:42 AM
Cleveland Enquiries oil pressure, compression pressure RevHeadRon Cleveland Tech 7 10-11-03 05:45 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome