P0340??? Anyone ever come across this and fix it? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-22-09, 03:17 PM Thread Starter
Registered User
 
Join Date: Oct 2009
Posts: 6
P0340??? Anyone ever come across this and fix it?

Trouble Code: P0340



Camshaft Position Sensor Circuit Malfunction
Possible Causes:


CMP circuit open
CMP circuit short to GND
CMP circuit short to voltage
SIG RTN open (VR sensor)
CMP GND open (Hall-effect sensor)
CMP circuit short to CMP2 circuit (if equipped)
CMP incorrectly installed (Hall-effect sensor)
Damaged CMP sensor shielding
Damaged CMP sensor
Damaged PCM

What Mountaineer is doing is it feels like it hesitates occasionally when putting my foot back on the throttle.


What are all these possibilities and what about cost? Thank you for taking the time to read this and also for any help, I appreciate it.

jrhernandez29 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome