Securilock light on and flashing light cut motor - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-05-11, 07:32 AM Thread Starter
Registered User
 
Join Date: Apr 2008
Posts: 20
Securilock light on and flashing light cut motor

Well I got back a problem I forgot about. The first rains fell yesterday and my motor cuts out when I flash the lights, from the wiper stalk. But not when I operate the front lights via the dash switch, clockwise. Also the securilock light comes and stays on after starting and randomly goes off.
Both these are related to the rain yesterday and expect more of the same since it now the rainny season. It developed last year but has no problem in normal car washing only when it rains.
I suspect a water leak somewhere but do not know where to start.
Any advice where to look? Thanks

BHAGAT is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome