shift stuck - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-01-09, 11:35 AM Thread Starter
Registered User
 
Join Date: Oct 2008
Posts: 6
shift stuck

got a little problem, yesterday i was getting ready to drive my explorer, and when i went to shift from park to drive, i noticed that while im able to shift the indicator doesnt move on the dash, all gears work, its just the indicator on the dash doesnt move, anyone kno what caused this and any solutions to get it fixed

Reddboss is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-04-09, 07:43 AM
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,481
Re: shift stuck

The dashshift selector is electronically controlled. The bad news is you'll probably have to replace the instrument cluster as the digital shift selector is undoubtedly linked. Unless it really annoys you, there's no threat to drive-ability and no rush on getting it fixed for proper vehicle operation.

'11 Ram Quad Cab 4x4 SXT 5.7L HEMI (stock); 48,500m
'06 Pontiac G6 GT 3.5L 220hp; 64,000m
'12 Chrysler 200 Limited 3.6L 283hp; 28,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome