Strange noise from MAF sensor?? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator Forum for discussion of the Ford Explorer, Ford Explorer Sport Trac, Mercury Mountaineer and Lincoln Aviator.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-17-03, 03:11 PM Thread Starter
Registered User
 
Join Date: Jul 2003
Posts: 5
Question Strange noise from MAF sensor??

95 Explorer-92,000 miles. After driving it home tonight I noticed a strange sound coming from the engine bay. It was coming from the air filter area. I took it apart and when I looked at the air filter I could tell the noise was coming from the MAF sensor(I think it's the MAF sensor). I put my hand over it and it would stop. To describe the sound is that it was sort of a "low pitch whistling" sound. Like I said before I think this is the MAF sensor. Please correct me if I'm wrong. Any ideas on what is going on? It run's good. Good idle,no hesitation. Thanks for your reply's!

jwjohn is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Explorer | Ford Explorer Sport Trac | Mercury Mountaineer | Lincoln Aviator


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 Taurus 3.0 Crank/Cam Sensor Noise Tom Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 22 04-10-10 08:28 AM
'01 GT Strange Noise mroach23 Ford Mustang Forum 3 07-03-03 05:19 PM
Strange Noise and Vibration lacampercop Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel 4 06-25-03 06:46 AM
STrange tapping noise coming from engine Solid_Snake General Tech 6 07-22-02 06:36 AM
Understanding Engine Management - Part 1 Dan [Sac] V6 and Hot4 Tech 0 12-11-01 01:08 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome