1994 4L Problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > V6 and Hot4 Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-16-2004, 18:18   #1 (permalink)
Registered User
 
Join Date: Nov 2004
Age: 32
Posts: 1
Question 1994 4L Problems

Hi everyone new guy here, I own a 94 explorer and I'am having a heck of a time trying to locate a missfire.

With no codes set off and what seems like a missfire, my truck is running very rough through out the RPM band. When the converter locks in overdrive the truck shakes so bad under load I cant accelerate unless in 3rd gear.

All my electronics and sensors are in working order having new plugs and wires I think no fulty sensors are to blame. I'm thinking its a vacume leak or mabe a clogged cat?

This all started when i had to hop over a curb about 10 inches tall. The truck took it a little hard shook good over it.

Anyone have any vacume problems that were hard to detect. I believe i might of shook somthing loose or clogged the cat. Any help is much appreciated.
Thankyou in advance
bad2kta is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > V6 and Hot4 Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1994 Tempo RELAY or FUEL PROBLEMS????? haileybutt Ford Tempo Forum | Mercury Topaz Forum 5 09-29-2005 20:22
Ford's experiences problems with new diesel; 6.0 Power Stroke is important test Stacy94PGT Diesel Tech 0 03-04-2003 06:32
Quality problems bedevil Jaguar's X-Type Stacy94PGT Ford Worldwide News 1 05-29-2002 22:19
Ford blames its suppliers for quality problems, demands improvement Stacy94PGT Ford Worldwide News 0 05-28-2002 09:58

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 21:27.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.