2000 Ranger 3.0 injector problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-13-09, 01:17 PM Thread Starter
Registered User
Join Date: Feb 2009
Posts: 32
2000 Ranger 3.0 injector problems

Starting a new post for a friend. 2000 Ranger 3.0 flex fuel. Original high mileage motor overheated and junked. He got a salvage yard motor, put in a new crank and pistons, bearings, etc. After getting everything buttoned up and firing the motor it ran for a little bit and then stopped. Motor locked up. He pulled a spark plug and there was wheat seed in the plug. Pulled the intake and it was full of wheat seed. Seems a field mouse decided it was a perfect place for his winter stash. While it was running it packed the cylinders with the seed so tightly that it locked up. He pulled the heads, cleaned everything, and buttoned up again. Motor cranks but does not run. Fuel pump energizes, fuel at schrader valve on fuel rail, injectors getting fire but will not run. Spray it with starting fluid and it will run. Put a reader on it and it pulled no codes. I cycled the key a few times and the theft light seemed to be flashing a code. Flased once and paused and then flashed six times. It kept repeating that cycle, once then six. Don't know if that means anything or not. Any suggestions?
Thanks, OzarkCountry
OzarkCountry is offline  
Sponsored Links
post #2 of 2 (permalink) Old 07-13-09, 01:35 PM
10 yr FLM Tech
fixitnowlt's Avatar
Join Date: Jul 2009
Location: Virginia Beach, VA
Posts: 130
Re: 2000 Ranger 3.0 injector problems

The PATS system disables the fuel. See the other post for more info.

LT Knowledge IS power 68 Mustang 200, 68 Mustang 302, 89 Tbird SuperCoupe, 94 Tbird 3.8, 94 Bronco XLT 351
fixitnowlt is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > V6 and Hot4 Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome