99 4.2L v6 F 150 stumbles accelerating - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > V6 and Hot4 Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-19-2003, 16:53   #1 (permalink)
Registered User
 
Join Date: Dec 2003
Posts: 2
Question 99 4.2L v6 F 150 stumbles accelerating

my truck stumbles during acceleration but only when the rpms are low. I changed the plugs and the problem went away for 3 months... then came back. so I changed the wires same thing the problem came back. Any ideas? A buddy of mine has the same problem with his truck. same engine and trans.

Last edited by TURBINSHAFT; 12-19-2003 at 16:59.
TURBINSHAFT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-02-2004, 09:18   #2 (permalink)
NB & NCII V8 Fairlanes
 
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 2,880
Re: 99 4.2L v6 F 150 stumbles accelerating

Make sure the wires ends and the distributor cap (or whatever they plug into at the non plug end) are made of the same metel (eg copper and copper). If they are not (i.eg different coloured metals) the metal will tend to corrode rapidly causing the sort of problems you are having. Try claening these bits with spray contact claener lubricant and a stiff nylon brush and see what happens. If you can't get matching components use ignition lubricant on these parts.
__________________
Regards Blue
Aussiblue is offline   Reply With Quote
Old 02-23-2004, 03:19   #3 (permalink)
TurbolaserS
 
turbolaser_92's Avatar
 
Join Date: Feb 2004
Location: wodonga
Age: 31
Posts: 49
Re: 99 4.2L v6 F 150 stumbles accelerating

It sounds like the motor is running rich.Which is why the problem went away when you replaced the plugs(The new ones were obviously clean and unfouled)Have you had the injectors cleaned? I'd replace the fuel filter and have your injectors cleaned,then have a mechanic shove a exhaust gas analyser up the exhaust and check the HC levels.
It may cost more money to have a mechanic look at but just replacing parts is never going to fix the problem.
turbolaser_92 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > V6 and Hot4 Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
99 mustang V6 Squeals when first starting josh627 V6 and Hot4 Tech 7 03-13-2004 10:18
99 mustang V6 Squeals when first starting josh627 V6 and Hot4 Tech 2 11-06-2003 06:13
FAQ: 3.8L V6 Ignition Surging LunaticSVT V6 and Hot4 Tech 0 07-15-2003 00:32
Fighting for HP: Florida vs. 99 SVT Cobra Stacy94PGT Ford Worldwide News 0 12-22-2001 23:41
Holdens V6 and V8 engine plans TurboDOHC The Pub 21 05-15-2001 07:40

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 19:50.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.