Quick Help! Intrument Cluster - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-27-06, 04:08 PM Thread Starter
Registered User
Join Date: May 2006
Posts: 3
Exclamation Quick Help! Intrument Cluster

I have installed a new glow gauge backing inside the insrument cluster...and i had to remove the dials it self...well after i was done butting the new backing on and putting the dials back on...everything went to crap. None of my gauges read correctly. I tried removing the negative line for a few minutes and turning the key to on to let the instruments reset, well they acted all stupid and they all read something different. I need some way how to reset them or put them back in place so i can drive again! I appreciate it if anyone could help me out!

I have:
01 Ford Mustang
V6 3.8L
zeldarich is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > V6 and Hot4 Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome