04 f-250 6.0 help please - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-24-12, 11:25 AM Thread Starter
Registered User
 
Join Date: Mar 2012
Posts: 2
04 f-250 6.0 help please

Went through high water changed air filter truck turns over and started once then died. Any suggestions?

Sent from my Motorola Electrify using AutoGuide.Com Free App

krebbs is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-24-12, 12:26 PM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: 04 f-250 6.0 help please

More info would help. Did you just splash a good amount of water over the engine, or did it enter the intake?
thefonz is offline  
post #3 of 4 (permalink) Old 03-24-12, 12:34 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,336
Re: 04 f-250 6.0 help please

As " the fonz " states , need more info . Depending how much water and whether it was sucked into engine . Check oil level and see if water in sump . If so you will have to drain it , but may also caused engine to hydraulic .
R.S.LOGAN is offline  
post #4 of 4 (permalink) Old 03-24-12, 10:46 PM Thread Starter
Registered User
 
Join Date: Mar 2012
Posts: 2
It splashed over the motor front end came.up out of water truck died I tried to start it once with exhaust in water it wouldn't pulled it out air filter was soaked changed it it started and ran for 30 sec still turning over pretty good but won't fire.
Sent from my Motorola Electrify using AutoGuide.Com Free App
krebbs is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Diesel Tech
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome