2000 7.3 loses power at times, then O.K. for awhile - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-08-06, 08:03 PM Thread Starter
Registered User
 
Join Date: Dec 2006
Posts: 1
2000 7.3 loses power at times, then O.K. for awhile

I just puchased a 2000 F-250 with 7.3 turbo diesel. Truck runs good most of the time, but then occasionally it just bogs out, no power. It does not miss on just some of the cylinders, but seems like a fuel restriction to all. I've changed the filter under the hood, no help there. Diesel shop put it on their computer - no codes, looks O.K. there. He thought maybe the batteries - so put in 2 new batteries - same problem.
I've got 4 ideas - anybody want to steer me right?
1. Plugged filters in tank - but then why would it run perfect sometimes??
2. Fuel pump on frame not pumping enough? Bad pump? Bad elec connection?
3. Slight leak in fuel line between tank and the pump on the frame, letting it suck in a little air?
4. Cam sensor bad - but they tell me they usually quit completely when they go?
P.S. I found the previous owner. He had it about 6 months and sold it because of this!! I didn't do carfax and track it back further, maybe should!
Thanks for any help!!!

Fencer is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Diesel Tech
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome