'02 Escape Transmission Issue - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-27-2007, 06:16   #1 (permalink)
Registered User
 
Join Date: Jun 2007
Location: Missouri
Posts: 2
confused '02 Escape Transmission Issue

I have an '02 escape with 119,000 miles. My O/D off light started flashing at highway speeds. Long story short, my mechanic pulled the transmission error code P0741. He said something about some faulty valve assembly that Ford has provided an "upgraded" assembly. Unfortunately, it comes in a rebuild kit. He wants to put a rebuilt trasmission in it. Has anyone else encountered this issue? If so, is this ultimately what you had to do? Any input or reccomendations would be appreciated.

Thanks.
wxman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-10-2007, 06:04   #2 (permalink)
fordmech
 
backlash1's Avatar
 
Join Date: Jun 2007
Location: NSW Australia
Age: 43
Posts: 315
Re: '02 Escape Transmission Issue

Hi
99% of the time, an Overdrive light flashing means your transmission is overheating. Before you blame this on the internals of the transmission check for leaks, damage to cooling lines, things that may be blocking the air flow and quality of the transmission fluid.
marc
backlash1 is offline   Reply With Quote
Old 07-23-2007, 18:26   #3 (permalink)
Registered User
 
Join Date: Jun 2007
Location: Missouri
Posts: 2
biggrin Re: '02 Escape Transmission Issue

After getting a second opinion on my transmission, unfortunately, they came to the same conclusion that the transmission needed to be rebuilt. Transmission was rebuilt and everything seems to working now.
wxman is offline   Reply With Quote
Old 06-28-2008, 08:09   #4 (permalink)
New England toolmaker
 
Join Date: Oct 2007
Location: Bantam, CT
Age: 67
Posts: 16
Re: '02 Escape Transmission Issue

Replacing the tranny is the easy way and probably the cheapest way, but is the rebuilt one goin to have the upgrade?
yankee is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 15:34.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.