08 Escape Hybrid Navigation DVD Not Working - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-10-10, 04:10 PM Thread Starter
Registered User
 
Join Date: Oct 2010
Posts: 1
08 Escape Hybrid Navigation DVD Not Working

I put a copy of friends Navteq DVD into my 08 Escape Hybrid navigation, it was the correct version and the original DVD worked fine. However the copy went in, the screen goes back up and it just says loading and making sounds like it's working, but after a half hour I still have a blank screen.

Now I have no navigation or menu options on the screen, radio/cd only. So I cannot access the eject option on the touchscreen to remove the DVD and put the working one back in.

I've tried waiting 1 hour plus with the car off and on. Tried disconnecting the battery, still nothing.

Does anyone know if there is an override or option to eject the DVD without going through the touchscreen menu? Hopfully using the buttons as that is all I can access.

Any ideas short of pulling my radio out and voiding warranty are appreciated!
-Jonny5
Jonny-5 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome