08 Escape start problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-15-08, 10:59 AM Thread Starter
Registered User
 
Join Date: Sep 2008
Posts: 1
08 Escape start problems

Ok, so I'm not too good with cars but I have an 08 escape that has trouble starting sometimes. All the lights and inside come on, I turn the key and it seems like it's starting, but keeps turning and turning and never fully starts. This happened about numerous times. Occasionally, I can try again and it will start, but at least a few times it doesn't start at all.

Not sure what to do? Took it in for repair and they couldn't reproduce the problem and upgraded the computer chip firmware or something, but they didn't know if that would fix it. It's a hard problem to have, because it's intermittent. I'm not sure if it's electrical or not.

dwd3885 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-20-08, 06:36 PM
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,481
Re: 08 Escape start problems

Does it seem to crank over steadily when cold only? or when the engine is warm as well? If it only happens with the engine cold, park it at a shop overnight and have them start it in the morning so you can better reproduce the problem. As it's a 2008 you should have warranty coverage from the dealer unless you're over the mileage.

'11 Ram Quad Cab 4x4 SXT 5.7L HEMI (stock); 48,500m
'06 Pontiac G6 GT 3.5L 220hp; 64,000m
'12 Chrysler 200 Limited 3.6L 283hp; 28,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome