'10 Mariner died while driving - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-23-2013, 11:10   #1 (permalink)
lbw
Registered User
 
Join Date: Jan 2013
Posts: 1
'10 Mariner died while driving

I have a 2010 Mercury Mariner, base model. Three days after I took delivery in 2010 it died while I was driving it and wouldn't restart. Dealer gave me a new battery and the next day I had a "brown out" (slow down) and took it back and they drove it and it died again, so they figured out it was a loose wire going to the electrical box. All was fine. Then about a year or so ago, I turned into a driveway and it stalled as I was still moving, and the dealer couldn't find anything.
(Meanwhile, I had to get the tranny overhauled after only a year, but that's another story. This car is shite.)
So I was driving about 25mph a week ago and first the radio turned off and then the car just slowed down. I was able to coast over to the side and turned it off. When I turned it off, the car shuddered a few times. Turned the key and it grinded for a second or two and then started. I was able to drive it to work and made the dealer come down and get it. They have now had it for FIVE DAYS and can't find anything. They keep driving it in an attempt to replicate the problem, which of course is not happening. They said they checked alternator, battery, throttle something or other and a lot of other things. So far they aren't finding anything.
Any ideas?? And what if they can't find anything? I do not want to drive this car ever again.
lbw is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-29-2013, 09:13   #2 (permalink)
Registered User
 
Join Date: Mar 2001
Location: gawga
Posts: 122
Re: '10 Mariner died while driving

Poor connection at the battery cables or the other end, starter relay and/or body ground.

I had a similar 'slow death' in my Ranger, and it turned out to be a loose connection on the battery. Radio quit, dash lights went, started to run poorly, barely made it up a hill, died at the peak, and coasted into a gas station. I was able to turn the cable on the battery post, and after tightening, everything went back to normal.
tom
tomw is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 01:29.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.