2003 Escape electrical problems? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-28-11, 05:41 PM Thread Starter
Registered User
 
Join Date: Mar 2011
Posts: 1
2003 Escape electrical problems?

Shortly after I start my Escape there are a series of 5 bells or dings that repeat 5 times and this series repeats again every half hour that the car remains running. Also the brake light and ABS light remain on and the cruise control does not work. The horn does work. Had it to a shop (not a ford dealer though) thinking it was the clock spring but was told that was not the problem. Any ideas as to what the problem might be would be helpful.

Thanks, Larry

Goheensford is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-28-11, 10:34 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,341
Re: 2003 Escape electrical problems?

Is the brake fluid reservoir full? The chimes sound like the seat belt warning.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome