2003 Escape Runs Rough after Rain... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 08-20-09, 09:21 PM Thread Starter
Registered User
 
Join Date: Mar 2008
Posts: 2
confused 2003 Escape Runs Rough after Rain...

Hi. My 2003 Escape XLT 4x4 has a rough idle and almost stalls when driving after it rains or when it gets wet (i.e. car wash). The engine light comes on and its seems like it will stall when approaching a shift speed.

After a day or so of nice weather the issue goes away, sometime it is a little rough starting for the first time.

Any ideas what could be causing this to happen?

Caper74

caper74 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 08-20-09, 09:41 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,326
Re: 2003 Escape Runs Rough after Rain...

Possible spark plug wire or any other type connection. If you get a spray bottle with water and with it running spray one area at a time to pinpoint where it is.
Bert is offline  
post #3 of 6 (permalink) Old 08-22-09, 09:34 AM
Registered User
 
hurk's Avatar
 
Join Date: Jun 2009
Posts: 96
Re: 2003 Escape Runs Rough after Rain...

It sounds like water is getting to the ignition components.
Are any of the splash shields, plastic cowlings or rubber seals missing or damaged?
hurk is offline  
post #4 of 6 (permalink) Old 08-24-09, 01:37 PM
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,481
Re: 2003 Escape Runs Rough after Rain...

If the engine light is on, get the code read and that will better pinpoint the source of the problem. If the engine light goes on and then doesn't come on after restarting, you can still download the engine code as they are stored for up to 50 restarts.

'11 Ram Quad Cab 4x4 SXT 5.7L HEMI (stock); 48,500m
'06 Pontiac G6 GT 3.5L 220hp; 64,000m
'12 Chrysler 200 Limited 3.6L 283hp; 28,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline  
post #5 of 6 (permalink) Old 05-24-11, 08:11 AM
Registered User
 
Join Date: May 2011
Posts: 1
Re: 2003 Escape Runs Rough after Rain...

I have had the same exact problem for the past two years! Yesterday it finally crapped out on the highway because of this issue. Sounds like a defect issue.
What is the official word on the cause of this?
Pete.c1 is offline  
post #6 of 6 (permalink) Old 05-25-11, 04:45 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,929
Re: 2003 Escape Runs Rough after Rain...

Sounds like it may be the ignition coils tracking / shorting out due to dampness , moisture .
R.S.LOGAN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome