2003 ford escape no power and rough idle 3.0 V6. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-30-14, 04:43 PM Thread Starter
2003 ford escape 3.0 V6
 
Join Date: Jun 2014
Location: florida
Posts: 1
2003 ford escape no power and rough idle 3.0 V6.

i have been having the same problem with my escape for over a month now. i took of the intake manifold to replace my spark plugs, and while i was doing that i noticed that most of my vacuum lines were becoming really dry rotted. so i replaced all the vacuum lines and fittings put the intake manifold back on. on the first start up it was running a little rough, found out i put the vacuum lines on incorrectly. fixed that problem and it ran great! the next day i changed my oil and flushed my coolant. and now its back to running like garbage >:( same problem as before rough idle, now power to push it down the road, and has a hard time revving above 2500 RPM. i have taken the intake manifold off three times now trying to see if there i messed up any vacuum lines, they all seem good. i have checked my EGR valve and solenoid they both seem to be operating as advertised. i have checked my CATS with a laser heat gun and they are operating as should be. i have no idea what to do next for trouble shooting this problem. i was thinking, could a AIC be causing this problem....? any ideas.....? thanks, and sorry for the long story lol :?
MEF_GUY is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-01-14, 07:08 PM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 5,450
Re: 2003 ford escape no power and rough idle 3.0 V6.

Any codes? Vacuum pressure? Fuel pressure?

Chewing on asphalt and drinking dinosaur wine
CatSkinner is offline  
post #3 of 3 (permalink) Old 07-02-14, 05:11 AM
Moderators
 
r-clar's Avatar
 
Join Date: Feb 2013
Location: Demotte Indiana
Posts: 1,884
Re: 2003 ford escape no power and rough idle 3.0 V6.

Could still be the cats. Try removing the front o2 sensors and see it it livens up. Not the proper way to do it but unless you have a back pressure gauge will have to do.


Sent from AutoGuide.com App
r-clar is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome